Как решить Composer Fatal error: Declaration of Fxp… must be compatible with …AbstractAssetsRepository.php?

Главная  >>  Backend  >>  Как решить Composer Fatal error: Declaration of Fxp… must be compatible with …AbstractAssetsRepository.php?

При установке, к примеру Yii2-пакета из композера Вы можете столкнуться с ошибкой «Composer Fatal error: Declaration of Fxp… must be compatible with …AbstractAssetsRepository.php». Так было и со мной, но я нашел быстрый и действенный способ решения проблемы, которым и хочу поделиться.

Итак, выполните последовательно в Терминале следующие действия:
— удаляем старый fxp:

— ставим новый fxp:

— делаем global update:

Секрет кроется в использовании опции --no-plugins.

Надеюсь статья была полезной для Вас! Удачи!